Get in touch
Back
Downtime

Scale platform currently out of use

Started 16 Aug at 01:37pm EEST, resolved 16 Aug at 04:00pm EEST.

Scale SaaS
Resolved

We have resolved the issue and all systems are running normally! Thank you for your patience.

Posted 16 Aug at 04:00pm EEST.
Created

We have identified a minor technical issue in our systems. We are working on fixing the issue and service will be available again very soon. Apologies for any inconvenience this may cause.

Posted 16 Aug at 01:37pm EEST.